Software installation troubles



  • I just got my LED and sensor boards from you folks and I'm trying to build the colorimeter. I think you folks are out of stock on the complete package colorimeter so I'm kind of starting from scratch. I have my own Arduino Uno and I've been able to upload the firmware however I've been having trouble with the software for the GUI. I have the latest version of Python on my computer (I have Windows 10) and tried running basic_ui.py from my terminal (using --> python basic_ui.py). But it says that there is no module named PyQt4 so I tried downloading that and it has trouble installing. I'm supposed to run 'python configure-ng.py' but it gives me and error that says "Could not find qmake configuration file win32-msvc2008." I tried looking up this error online and there are a few solutions but I haven't been able to get them to work (e.g. manually pass --spec win32-msvc). I figured I might have better luck asking you folks.

    Thanks,

    Lilia



  • @liliagwc

    You can download the colorimeter python software as a single executable (packaged using pyinstaller) from here https://bitbucket.org/iorodeo/colorimeter/downloads/colorimeter-v05.exe



  • @Will-Dickson

    If you want to install the software from source you can get some prebuilt wheel packages for windows here https://www.lfd.uci.edu/~gohlke/pythonlibs/#pyqt4

    Note, the colorimeter software only supports python 2.7 at this time. So you will want to have python 2.7 installed and you will want a version of PyQt4 with cp=27 in the name.



  • Oh that's great! I tried the single executable file and it worked. I guess I had trouble finding that earlier. Thanks so much Will!


Log in to reply